Skip to main content
All CollectionsDonut for SlackDonut Channels: Celebrations
Donut Celebrations: Solving CSV Import Errors
Donut Celebrations: Solving CSV Import Errors

How to identify, avoid, or resolve common errors that you may receive when uploading dates for your Donut Celebrations channel.

Essence avatar
Written by Essence
Updated this week

A .csv file can be used to upload your teammates' birthdays and work start dates to your Donut Celebrations channel. To ensure a successful import, please download the template we provide and follow these data requirements:

  • The email addresses must derive from the users' Slack credentials.

  • The date format may be mm/dd/yyyy or dd/mm/yyyy. (Please download the corresponding template for the format you decide to use).

  • The file must be exported in CSV format.

If the information in your file is not entered or formatted correctly, you should receive an error message that identifies the problem and the affected row.

The following information can help you troubleshoot the errors that you might receive:

Error

Cause

No email

The email address is missing from the row.

Invalid Date

The date is not in mm/dd/yyyy or dd/mm/yyyy format.

Examples: 2021/09/21, 87/32/9009, 12-09-2021

No member of your Slack workspace found for the email

The email address is not linked to the person's Slack account.

Invalid CSV header

The CSV header doesn't match the provided templates.

Invalid CSV formatting

The CSV file was exported in an unsupported format.

Examples: RFC 4180 and MIME standards, OKF, or W3C

Unknown error

This error is uncommon; if you receive this, please reach out to support@donut.ai, and we will look into this for you!


If you have any questions or feedback, click the purple Donut button on the bottom right of your screen to open up a chat with our support team!

Did this answer your question?